KarteikartenTrainer

Das Programm KarteikartenTrainer dient seit 1997 dem Erlernen von allem, was man auch auf reale Karteikarten schreiben könnte:
  • Vokabeln
  • Kurzfragen
  • Fachtermini
  • usw.
Dabei kann jede Karteikarte mit einer Grafik oder einer chemischen Strukturformel verknüft werden. Die Grafiken müssen im jpg oder bmp Format vorliegen und die Strukturformeln mit dem Strukturformeleditor erstellt worden sein. (www.strukturformeleditor.de)

Die Nutzung des Programm ist denkbar einfach: Es ist in drei Bereiche gegliedert, die über die Laschen am unteren Bildrand angewählt werden können:
  • Der Bereich Lernen ist der wesentliche Arbeitsbereich: Hier werden die Karteikarten geübt. Die Erfolgskontrolle erfolgt durch Selbstbewertung.
  • Der Bereich Neu dient der Eingabe von neuen Karteikarten.
  • Der Bereich Liste ermöglicht den Überblick über den gesamten Datenbestand der aktuellen Datei.
Für viele weitere Optionen steht Ihnen das Menü am oberen Fensterrand zur Verfügung.


3 Modi

Lernen, Neue Eingabe, Übersichtsliste

Das Programm ist in drei Bereiche gegliedert, die über die Laschen am unteren Bildrand angewählt werden können:

Lernen:
Nachdem die Frage gezeigt wurde, überlegen Sie bis Sie die Antwort zu kennen glauben und klicken dann auf weiter. Nun wird Ihnen die korrekte Antwort gezeigt und Sie bewerten, ob Ihre gedachte Antwort korrekt oder falsch war.
Zu jeder Karteikarte wird die Information gespeichert, wie oft Sie diese hinereinander korrekt beantwortet haben, ohne einmal eine falsche Antwort zu geben.
Im unteren Fensterbereich wird Ihnen in einem Tortendiagramm, angezeigt, wie viele der Karteikarten Sie hintereinander bereits mindestens vier mal (dunkelgrün), zweimal (hellgrün), einmal (gelb) oder bei der letzten Abfrage nicht (rot) korrekt beantwortet haben. Über dem Tortendiagramm steht, welche Karteikarte gerade angezeigt wird und wie oft Sie diese bereits hintereinander korrekt beantwortet haben.
Ein Klick mit der rechten Maustaste auf Frage oder Antwort öffnet ein Popup-Menü, das das Bearbeiten und das Überspringen der aktuellen Karteikarte zulässt.

Neu
Sie geben Frage und Antwort ein und fügen ggf. noch eine Verknüpfung zu einer Grafik hinzu. Danach klicken Sie auf weiter und können nun die nächste Karteikarte erstellen.
Um Sonderzeichen komfortabel einzugeben, können Sie auf den mit Š beschrifteten Button im unteren Fensterbreich klicken. Nun öffnet sich eine virtuelle Tastatur mit den verfügbaren Sonderzeichen. Um anderen Sonderzeichen (z.B. griechische oder kyrillische Buchstaben) nutzen zu könne, müssen Sie im Menü Suchen & Ansicht auf den Punkt Schrift für... klicken und dort den passenden Zeichensatz auswählen (bei Skript z.B. griechisch auswählen)

Liste
In dieser Liste werden Ihnen alle Karteikarten des aktuellen Karteikartensatzes in alphabetischer Reihenfolge angezeigt. Durch einen Doppelklick auf einen Eintrag können Sie diesen in einem separaten Fenster bearbeiten. Mit der Entfernen-Taste oder der Backspace-Taste können Sie einzelne Einträge löschen.


Menue

Das Menü

Datei

  • Neu: Öffnet eine neue, leere Karteikartendatei. Denken Sie daran, diese vor dem Beenden des Programms mit Sichern als zu speichern.
  • Laden: Öffnet eine bestehende Karteikarten-Datei.
  • Sichern als: Die aktuelle Karteikarten-Datei wird unter einem neuen Namen gespeichert. (Es existiert kein Speichern-Menüpunkt, da Änderungen an der aktuellen Datei immer sofort gespeichert werden)
  • Sonstiges:
      • Karteikarten aus dem Internet: Die Webseite www.KarteikartenTrainer.de wird geöffnet.
      • Eigene Karteikarten veröffentlichen: Es öffnet sich Ihr E-Mailprogramm. Wenn Sie Ihre Dateien anderen Nutzern kostenlos zur Verfügung stellen möchten, schicken Sie Ihre Datei bitte an info@s-implesoft.de.
      • Karteikarten-Datei hinzufügen: Der aktuellen Datei wird eine weitere Datei im Karteikarten-Format (*.kkt) hinzugefügt.
      • Import aus Textdatei: Es stehen verschiedene Importformate offen. Allerdings ist nur das Format "..." ; "..." in der Lage Zeilenumbrüche zu berücksichtigen.
      • Export in Textdatei: Es stehen verschiedene Exportformate offen. Allerdings ist nur das Format "..." ; "..." in der Lage Zeilenumbrüche zu berücksichtigen.
      • Lernen auf einem Palm: Die aktuelle Datei kann hier für die nächste Synchronisation mit einem PDA mit Palm OS und der Software Meistermerker markiert werden. Die Software Meistermerker ist unter http://user.cs.tu-berlin.de/~jonash/palmos/palmos_apps.html kostenlos erhältlich.
  • Datei-Info: Hier können Informationen zu der aktuellen Datei (Autor, Inhalt, Buchempfehlung) eingegeben bzw. eingesehen werden.
  • Drucken: Es werden Vorder- und Rückseiten der Karteikarten (ggf. mit Bild oder Strukturformel) gedruckt. (8/Seite)
  • Direktzugriff auf Karteikarten-Dateien: Die letzten drei genutzen Dateien werden hier aufgelistet und können direkt geöffnet werden
  • Beenden: Schließt das Programm

Abfrageverhalten

  • Andere Richtung: Ist hier ein Haken gesetzt, werden die Antworteseiten zunächst angezeit und die Frageseite der Karte erst nach einem Klick auch weiter enthüllt. Diese Funktion ist vor allem bei Vokabeln sinnvoll, die in beide Richtungen gelern werden sollen.
  • Alle auf Null: Zu jeder Karteikarte wird eine Information gespeichert, wie oft, diese Frage hintereinander korrekt beantwortet wurde. Diese Information wird genutzt um zu definieren, wie häufig diese Karte in der Zukunft abgefragt werden soll. Durch Klick auf diesen Menüpunkt wird diese Information gelöscht und auf den Wert Null gesetzt.
  • Unabhängig von richtiger Beantwortung: Während des Lernens werden Karteikarten zufällig ausgewählt und nicht in Abhängigkeit davon, wie häufig diese in der Vergangenheit richtig beantwortet wurden.
  • lineare, quadratische und kubische Abhängigkeit: Diese Information gibt an, wie die Anzahl der korrekten Beantwortungen einzelner Karten in der Vergangenheit gewichtet werden soll. Lineare Abhängigkeit bedeutet, dass eine Karte, die in der Vergangenheit z.B. 2 Mal korrekt beantwortet wurde, doppelt so wahrscheinlich erneut gefragt wird wie eine Karte, die bereits 4 Mal korrekt beantwortet wurde. Bei kubischer Abhängigkeit würde sie 8 mal so wahrscheinlich gefragt.
  • Der Reihe nach Lernen: in diesem Modus wird nach dem Beantworten einer Karte die in der Datei jeweils nächste Karteikarte gefragt. Also ist die Abfragereihenfolge hier gleich der Erstellreihenfolge.

Suchen & Ansicht

  • Suchen: Ermöglicht es bestimmte Karten in der aktuellen Datei anhand von Suchbegriffen zu finden. Dabei kann gezielt nur auf Frage- oder Antwortseite oder auf beiden Seiten gesucht werden.
  • Karten linksbündig: Beim Lernen werden die Karten linksbündig ausgerichtet (sinnvoll bei längeren Textfragen / Antworten).
  • Karten zentriert: Beim Lernen werden die Karten zentriert ausgerichtet (sinnvoll bei Vokabeln).
  • Automatisch Grafik anzeigen: Enthält eine Frage / Antwort eine Grafik, so wird diese immer als kleines Vorschaubild angezeigt. Ist diese Option gewählt, so wird die Grafik immer automatisch auch im großen Anzeigefenster angezeigt. Andernfalls geschieht dies erst nach einem Klick auf den Frage- / Antworttext oder das Vorschaubild.
  • Schrift für Fragen / Antworten: Hier kann die Schrift für die Fragen bzw. Antworten festgelegt werden. Informationen zur Schriftart und der Codepage (westlich, griechisch, kyrillisch ...) werden in der Karteikartendatei gespeichert. Die Schriftgröße hingegen stellen Sie nur für die Betrachtung auf Ihrem Computer ein.

Hilfe

  • Hilfe: Hier finden Sie die Hilfe, die Sie gerade lesen.
  • Registrieren: Unterstützen Sie die Weiterentwicklung dieses Programms mit ein paar Euro und erhalten Sie als Dankeschön Zugriff auf die Such- und Druckfunktion
  • About: Hier finden Sie Informationen zu uns und zu der Version des KarteikartenTrainers.


Karteikarten laden / bereitstellen

Karteikartensätze

Bereits bestehende Karteikarten-Dateien nutzen

Auf der Seite www.karteikartentrainer.de haben Nutzer des KarteikartenTrainers in den Jahren seit 1997 viele Karteikartensätze für die Öffentlichkeit - also für Sie - zur Verfügung gestellt. Die meisten Daten sind dort per Zip komprimiert und müssen vor der Nutzung entpackt werden. Sie können diese Daten kostenlos herunterladen und nutzen. Bitte bedenken Sie, dass es sich nicht um redaktionell bearbeitete Inhalte handelt, für die keinerlei Garantie übernommen wird.

Eigene Dateien zur Verfügung stellen

Haben Sie selber Karteikartensätze erstellt, die auch für andere Nutzer von Intersse sein könnten? Dann schicken Sie diese bitte per E-Mail an info@s-implesoft.de, damit wir Sie auf www.karteikartentrainer.de online stellen können.


Datei-Informationen

Karteikarten

Jede Karteikarte kann auf der Frageseite 255 Zeichen und auf der Antwortseite 512 Zeichen Text enthalten. Diese Restriktion ist beabsichtigt, da gute Karteikarten zum Lernen kurz gehalten sein sollten.

Informationen zur Schriftart

Jede Karteikarten-Datei enthält für Frage und Antwortseite getrennt die Information, welche Schriftart und welche Codepage (westlich, griechisch, kyrillisch...)
verwendet werden soll.

Inhalt & Autor

Jede Karteikarten-Datei enthält -sofern vom Anwender eingegeben- Informationen über den Autor der Datei, den Inhalt und eine Buchempfehlung. Die Informationen sind über das Menü Datei|Datei-Info aufrufbar.


Registrierung

Programmentwicklung unterstützen

Das Programm Karteikartentrainer kann von Ihnen für private, nicht-kommerzielle Zwecke zeitlich unbegrenzt genutzt werden. Es gibt viele Schüler und Studenten, die nur sehr wenig Geld zur Verfügung haben und die auf kostenlose Software angewiesen sind.
Sollten Sie das Glück haben, nicht jeden Cent umdrehen zu müssen, würden wir uns freuen, wenn Sie die Weiterentwicklung des Programms mit ein paar Euro unterstützen würden. Als Dankeschön schalten wir in Ihrer Version des KarteikartenTrainers auf Ihrem Rechner zwei zusätzliche Funktionen (Such- und Druckfunktion) frei.

Weitere Informationen finden Sie unter www.karteikartentrainer.de/registrierung.html


Impressum

Das vorliegendeProgramm wurde hergestellt von der

Buchholz Wengst GbR - SimpleSoft
Dürerstraße 3
38106 Braunschweig

Bitte wenden Sie sich bei Fragen, Verbesserungsvorschlägen oder falls Sie Unstimmigkeiten entdecken an Martin Buchholz (info@s-implesoft.de).

Nutzungsrechte:

Alle Rechte für diese Software liegen bei der Buchholz Wengst GbR. Sie erhalten jedoch das Recht diese Software zeitlich unbeschränkt für private, nicht kommerzielle Zwecke zu nutzen. Insbesonder die Nutzung an Schulen oder Universitäten ist erlaubt und erwünscht.
Sollten Sie an einer Nutzung innerhalb gewerblicher Strukturen interessiert sein, wenden Sie sich bitte ebenfalls an info@s-implesoft.de.